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Software Copyright 

The Broad Institute  
SOFTWARE COPYRIGHT NOTICE AGREEMENT  

This software and its documentation are copyright 2006 by the Broad Institute/Massachusetts Institute of Technology. 
All rights are reserved.  

This software is supplied without any warranty or guaranteed support whatsoever. Neither the Broad Institute nor MIT 
can be responsible for its use, misuse, or functionality. 



The GenePattern Tutorial introduces you to GenePattern by providing step-by-step instructions for analyzing gene 
expression. GenePattern provides two user interfaces, the Web Client and Desktop Client: 

● Part 1 provides instructions for the Web Client 

● Part 2 provides instructions for the Desktop Client 

Both parts use the same example session. Each part is independent; you can run through Part 1, Part 2 or both. 

 

About GenePattern Describes the GenePattern platform. 

Installing GenePattern Describes how to install the GenePattern software. 

Scientific Scenario Describes the example dataset that you will use and the 
analyses that you will perform. 

Starting the GenePattern Server Describes how to start the GenePattern server. 

Part 1: Using the GenePattern Web Client Provides step-by-step instructions for running the 
analyses in the Web Client. Estimated time: 90 minutes 

Part 2: Using the GenePattern Desktop Client Provides step-by-step instructions for using the Desktop 
Client. Estimated time: 90 minutes 

Part 3: Shutting Down the GenePattern Server Provides step-by-step instructions for exiting from 
GenePattern. 

 

All of the information you need to successfully complete this tutorial is contained in the tutorial. For users who like 
additional discussion along the way, the tutorial includes pointers to more information in other GenePattern guides. 
Feel free to follow these links or to ignore them, depending on your learning style. 
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About GenePattern 
GenePattern is a client-server application that provides access to a broad array of computational methods used to 
analyze genomic data: 

● The server is the GenePattern engine that runs the analyses and stores analysis results. The GenePattern 
server can be installed on your desktop computer or installed in a networked location for use by multiple users.  

● The client is the user interface that you use to interact with the GenePattern server. You can use one of three 
GenePattern clients: 

▪ The Web Client provides access to GenePattern from any web browser. This interface provides easy access 
to GenePattern for users of all levels, as well as providing access to server administration functions.  

▪ The Desktop Client, which you download and install, provides access to GenePattern from a Java 
application that you run on your desktop computer. This interface provides easy access to GenePattern for 
users of all levels. 

▪ The Programming Environment provides access to GenePattern from the Java, MATLAB, and R 
programming environments. It allows programmers to access GenePattern from their applications. 

This tutorial introduces you the Web Client and the Desktop Client. It does not cover the programming environment. 

Installing GenePattern 
To follow the hands-on instructions in this tutorial, you must have done the following: 

● Installed the GenePattern server 

● Installed the following modules: ComparativeMarkerSelection, ComparativeMarkerSelectionViewer, 
ExtractComparativeMarkerSelection, and HeatMapViewer 

● Downloaded the sample datasets 

For instructions on installing GenePattern and its modules, see the installation instructions.  

Scientific Scenario 
The gene expression dataset used in the tutorial is from Golub and Slonim et al. (1999), which used clustering and 
prediction algorithms to find genes that distinguish between two subtypes of leukemia, ALL and AML. The dataset 
consists of 38 bone marrow samples (27 ALL, 11 AML) obtained from acute leukemia patients. 

For the purposes of this tutorial, your goal is identify marker genes for the two subtypes of leukemia: 

1. You use the ComparativeMarkerSelection (version 3) analysis to find the genes in the dataset file that are most 
closely correlated with the two subtypes of leukemia. 

2. You use the ComparativeMarkerSelectionViewer (version 4) to examine the results of that analysis. 

3. You use the ExtractComparativeResults (version 3) analysis to create a new dataset that contains the marker 
genes that you have identified. 

4. You use the HeatMapViewer (version 5) to examine the expression levels of the marker genes and to confirm 
that the marker genes are clearly differentially expressed in the two subtypes of leukemia. 

Note: Analysis modules are regularly updated. If you have a more recent version of any module, follow the 
instructions as closely as possible, but be aware that your results might not match those shown in the tutorial. 

Starting the GenePattern Server 
You must start the GenePattern server before you can start either the GenePattern Web Client or the GenePattern 
Desktop Client. The server takes several seconds to start; clients cannot connect to it while it is starting. 

To start the GenePattern server, double-click the Start GenePattern Server icon, shown below. By default, the 
GenePattern installation places this icon on your desktop. 

http://www.broad.mit.edu/cancer/software/genepattern/download/
http://www.broad.mit.edu/cgi-bin/cancer/publications/pub_paper.cgi?mode=view&paper_id=43


 
On Windows, while the server is starting, a console window displays messages. The server is ready when the 
console displays the following message: 

 
On Mac OS X, while the server is starting, the server icon bounces in the Dock. The server is ready when the icon 
stops bouncing. If you want to read the messages, see the Console. 

Part 1: Using the GenePattern Web Client 
This part of the tutorial introduces you the GenePattern Web Client. In this part, you learn how to:  

● Start the Web Client. 

● Run analyses. 

● Review analysis results. 

● Save and delete analysis results files. 

● Create a pipeline that runs a sequence of analyses. 

If you would rather use the GenePattern Desktop Client, go to Part 2: Using the GenePattern Desktop Client. 

Starting the Web Client 
To start the GenePattern Web Client: 

1. Double-click the GenePattern Web Client icon. By default, the GenePattern installation places this icon on your 
desktop. 

 
The Web Client displays the login page starts in your default web browser. This figure shows the login page 
prompting only for a username; you might also be prompted for a password. 

Note: The pictures in the tutorial show the Web Client running in a Firefox web browser on a Windows PC. If you 
are using a different web browser or a different operating system, your screen may look slightly different. 

2. Enter your username, or your username and password. 

3. Click Sign In. The Web Client displays the start page. 
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Notice the following elements of the Web Client start page: 

● The URL shows you the GenePattern server that you are using. The Web Client, which remains connected to the 
server throughout the session, runs all of your analyses on this server.  

● The upper right corner shows your user name. Typically, your GenePattern user name is your e-mail address. 

● The Modules & Pipelines panel lists the analyses that you can run. By default, the analyses are organized by 
functional category. 

● The center panel, which displays the welcome message, is the main display panel for the Web Client. The Web 
Client uses this panel to display information and to prompt you for input. 

● The Recent Jobs panel lists the last four analyses that you have run and their generated analysis results files.  
When you first start the Web Client, this panel is empty. 

● The navigation bar provides access to other Web Client pages. 

For more information: see Exploring the User Interface in the GenePattern Web Client Guide. 

Running Analyses 
Now that you have started the GenePattern server and Web Client, you are ready to analyze your data. In this 
section, you learn how to: 

● Run the ComparativeMarkerSelection analysis to find marker genes -- the genes in the dataset that are most 
closely correlated with the two phenotypes (ALL and AML) in the dataset. 

● Run the ComparativeMarkerSelectionViewer to examine the ComparativeMarkerSelection analysis results. 

● Run the ExtractComparativeResults analysis to create a smaller dataset that contains only the marker genes. 

● Run the HeatMapViewer to examine the expression levels of the marker genes. 
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Running Comparative Marker Selection 
Run the ComparativeMarkerSelection analysis to find the genes in the dataset that are most closely correlated with 
the two phenotypes (ALL and AML) in the dataset. To run the ComparativeMarkerSelection analysis: 

1. In the Modules & Pipelines panel, under Gene List Selection, select the ComparativeMarkerSelection analysis. 
The analysis and its parameters appear in the center panel. 

 
2. For information about the module and its parameters, click help. 

3. For the input filename parameter, select the all_aml_train.res file: 

1. Click the Browse button. The File Upload window appears. 

2. Navigate to the folder containing the file. 

3. Select the file and click Open. 

Leave the Upload File radio button selected to indicate that you are selecting a file from the file system. You 
would use the Specify URL radio button to select a networked file by specifying its URL. 

4. For the cls filename parameter, select the all_aml_train.cls file. 
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5. Click Run to start the analysis. The Web Client sends the analysis job to the GenePattern server and displays 
the ComparativeMarkerSelection Status page. After a few seconds, the GenePattern server finishes the analysis 
job and displays the results on the Status page. 

Analysis results are stored on the GenePattern server. By default, analysis results are stored for seven (7) days 
before being deleted. The text shown in a bold red font tells you when the analysis results will be deleted. To 
save your analysis results, copy the files from the GenePattern server to your own directories, as described later 
in this tutorial. 

 
6. Click Return to Modules & Pipelines Start to return to the Web Client start page. 

Reviewing Result Files 
When you return to the Web Client start page, the Recent Jobs pane shows the analysis job that you ran on the 
GenePattern server and the associated analysis results files: 
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1. Click the icon next to the analysis job to display commands that you use to work with the job: 

Download Downloads a zip file containing all analysis results files for this job. 

Reload Displays the analysis and its parameters in the center pane, with the parameters set to 
the values used for this analysis job.  

Delete Deletes the analysis job and its analysis results files from the GenePattern server. 

Info Displays the parameter values and the analysis results files for this job. 

View Java Code 
View MATLAB Code 
View R Code 

Displays the command line that you would use to run this job in the Java, MATLAB, or 
R programming environments. These commands are useful for programmers who 
want to access GenePattern from one of these programming environments or from 
their own applications. 

 

2. Click the icon next to an analysis results file to display commands that you use to work with the file: 

Delete Deletes the file from the GenePattern server. 

Save Downloads the file from the GenePattern server. 

Create Pipeline Creates a GenePattern pipeline that reproduces this analysis results file. 
Pipelines are discussed later in this tutorial. 

List of analyses Lists analyses that commonly use this type of file as an input parameter. 

Select an analysis to display its parameters in the center pane, with this results 
file specified as the first input parameter.  
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3. Click the analysis results file, all_aml_train.comp.marker.odf, to display it in a text viewer. The amount of 
information it contains makes the file difficult to understand. This file, like most analysis results file, is not 
intended to be viewed as a text file, but rather intended to be used as input to subsequent analyses. 

4. Click the Back button in your web browser to return to the Web Client start page. 

Running the Comparative Marker Selection Viewer 
After running the ComparativeMarkerSelection analysis, run the ComparativeMarkerSelectionViewer to examine the 
analysis results. To run the ComparativeMarkerSelectionViewer: 

1. In the Recent Jobs pane, click the icon next to your all_aml_train.comp.marker.odf results file. 

2. Select ComparativeMarkerSelectionViewer. The ComparativeMarkerSelectionViewer and its parameters appear 
in the center pane. The comparative marker selection filename parameter is automatically set to the 
all_aml_train.comp.marker.odf results file. 

 

3. For the dataset  filename parameter, click Browse and select the all_aml_train.res file. 

4. Click Run. 

Unlike most analyses, viewers run on your desktop PC rather than on the GenePattern server. The first time you 
run a viewer on your desktop, the following security message may appear.  

 
5. If the security message appears, click Run to continue. 

The ComparativeMarkerSelectionViewer appears: 
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6. In the ComparativeMarkerSelectionViewer: 

▪ The Score column shows the value of the metric used to correlate gene expression and phenotype. A high 
score indicates correlation with the first phenotype (upregulated in ALL) and a low score indicates correlation 
with the second phenotype (upregulated in AML). 

▪ The middle columns, FDR through FWER, provide different ways to measure the significance of the score. 
The lower the value the more significant the result. For example, you might choose to measure significance 
using the false discovery rate (FDR) and set a significance cutoff of FDR < .05. Using this measure, you 
would focus on genes with the lowest and highest scores, where the measure of significance for the score 
was an FDR < .05. 

7. To close the ComparativeMarkerSelectionViewer, select File>Exit. 

8. In the Web Client, click Return to Modules & Pipelines Start to return to the Web Client start page. 

Notice that the ComparativeMarkerSelectionViewer analysis does not appear in the Recent Jobs pane. This is 
because the ComparativeMarkerSelectionViewer ran on your local PC, not on the GenePattern server. 
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Running Extract Comparative Results 
Now that you have examined the ComparativeMarkerSelection analysis results, you want to create a new dataset 
that contains only the most promising marker genes from the results file for further analysis. To run the 
ExtractComparativeResults analysis: 

1. In the Recent Jobs pane, click the icon next to the ComparativeMarkerSelection results file, 
all_aml_train.comp.marker.odf. 

2. Select ExtractComparativeMarkerResults. The ExtractComparativeMarkerResults analysis and its parameters 
appear in the center pane. The comparative marker selection filename parameter is automatically set to the 
all_aml_train.comp.marker.odf results file. 

3. For the dataset  filename parameter, click Browse and select the all_aml_train.res file. 

4. Enter the following parameter values to extract the top 100 features (genes) in the analysis results file: 

▪ For the field parameter, select Rank. 

▪ For the max field, enter 100. 

 
5. Click Run. The Status page appears and, after a few seconds, displays the analysis results files. 
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6. Click Return to Modules & Pipelines Start to return to the Web Client start page. 

Running the Heat Map Viewer 
The HeatMapViewer displays expression values in a color-coded heat map. The largest expression values are 
displayed in red (hot) and the smallest values are displayed in blue (cool). Intermediate values are displayed in 
different shades of red and blue. The color-coding provides a quick coherent view of gene expression levels. 

To display your new dataset in the HeatMapViewer: 

1. In the Recent Jobs pane, click the icon next to the results file from the ExtractComparativeMarkerResults 
analysis, all_aml_train.comp.marker.filt.res. 

2. Select HeatMapViewer. The HeatMapViewer and its parameters appear in the center pane. The dataset  
filename parameter is automatically set to the all_aml_train.comp.marker.filt.res results file. 

 
3. Click Run. The HeatMapViewer appears: 
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4. In the HeatMapViewer, adjust the grid size for a clearer view of the sample and feature names: 
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1. Click Edit>Display Options. 

2. Click-and-drag the Grid Size  slider 4 or 5 points to the right. The Viewer displays the grid using larger cells.  

5. To close the HeatMapViewer, select File>Exit. 

6. In the Web Client, click Return to Modules & Pipelines Start to return to the Web Client start page. 

Using Pipelines 
As you have seen, the GenePattern Web Client makes it easy to run individual analyses and to review analysis 
results. GenePattern pipelines take this one step further: they make it easy to run multiple analyses. You can define a 
pipeline to run multiple analyses against a single dataset or to run a sequence of analyses, where the output from 
one analysis becomes the input for a subsequent analysis. Modules run from a pipeline work exactly the same as 
those run directly from the Web Client. 

In this tutorial, you have run two analyses: Comparative Marker Selection and Extract Comparative Marker Results. 
The analysis results file from the first analysis became the input file for the second analysis. Running these two 
analyses produced a new dataset that contains the 100 genes in your dataset (all_aml_train.res) that are 
most closely correlated with phenotypes in your class file (all_aml_train.cls). 

In this section, you will 

● Create a pipeline that duplicates your analysis results. 

● Edit the pipeline so that it operates on any set of data (res and cls) files. 

For more information: see Working with Pipelines in the GenePattern Web Client Guide. 

Creating a Pipeline Based on Previous Results 
You can create a pipeline in one of two ways: 

● You can create an empty pipeline and then add to it the analysis modules that you want the pipeline to run.  

● You can create a pipeline based on an analysis results file. In this case, GenePattern adds to the pipeline the 
analysis modules used to create that results file: 

1. It adds the module that created the results file. 

2. It checks the module’s input file parameter. 

3. If the input file for the module was the output file of a previous module, the GenePattern adds the previous 
module and returns to step 2; otherwise, there are no more modules to be added to the pipeline. 

To create a pipeline based on the ExtractComparativeMarkerResults results file: 

1. In the Recent Jobs pane, click the icon next to the results file from the ExtractComparativeMarkerResults 
analysis, all_aml_train.comp.marker.filt.res. 

2. Select Create Pipeline. The Web Client displays the new pipeline in the center pane. 

The new pipeline includes the module that created the results file, ExtractComparativeMarkerResults. The new 
pipeline also includes the ComparativeMarkerSelection analysis because the input file for 
ExtractComparativeMarkerResults was the output file from the ComparativeMarkerSelection analysis. The 
parameters for both analyses are set to the values used to generate the results file. (You will need to scroll to 
see the entire pipeline.) 



 
3. By default, the pipeline name is the job number. Change the pipeline name to MyComparativeMarkerSelection 

by editing the Pipeline name field. 

Adding Modules to a Pipelines 
The pipeline contains the two analysis modules used to create the analysis results file: Comparative Marker Selection 
and Extract Comparative Marker Results. In your original analysis, after creating the analysis results file, you used 
the Heat Map Viewer to review the results. 

To add the Heat Map Viewer module to your pipeline: 

1. Scroll to the end of the pipeline definition. 

2. Click Add Another Module to add a module after the ExtractComparativeMarkerResults analysis. The Web Client 
prompts you for the module to add: 
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3. Select Visualizer as the category and HeatMapViewer as the module: 

 
The Web Client adds the HeatMapViewer module to the pipeline: 

 
4. For the dataset filename parameter, select the analysis results file from the ExtractComparativeMarkerResults 

module. To do so: next to use output from, choose ExtractComparativeMarkerResults as the module and res 
as the output file: 

 
5. Click Save to save the pipeline. The Web Client displays a status page. 

6. Click Return to Modules & Pipelines Start to return to the start page. 

Running the Pipeline 
To run the pipeline: 

1. In the Modules & Pipelines pane, select your pipeline. (Notice that the pipeline names are color-coded; the 
pipelines you create are displayed in red.) The Web Client displays the pipeline and its parameters in the center 
pane. 

2. Click Run to run the pipeline. The Status page appears and GenePattern runs each module. After a few 
moments, GenePattern displays the analysis results and opens the HeatMapViewer. 

3. Close the HeatMapViewer. 

4. In the Web Client, click Return to Modules & Pipelines Start to return to the Web Client start page. 

The Recent Jobs pane shows the pipeline job, which lists each analysis run and its analysis result files. 

Adding Parameters to a Pipeline 
You have created a pipeline that duplicates your original analysis: it runs the Comparative Marker Selection analysis 
on the all_aml_train data (res and cls) files, uses the analysis results as input to the Extract Comparative 
Marker Results analysis, and then displays the analysis results using the Heat Map Viewer. 

You can make the pipeline more generally useful by having it prompt you for the data (res and cls) files to be 
analyzed, rather than simply analyzing the all_aml_train data files. 

To edit the pipeline: 
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1. In the Modules & Pipelines pane, select your pipeline. The Web Client displays the pipeline in the center pane: 

 
2. Click Edit. The Web Client displays the pipeline definition for editing. 

3. The data (res and cls) files to be analyzed are named in the input filename and cls filename parameters of the 
Comparative Marker Selection analysis. Modify the pipeline to have it prompt you for these parameter values: 

1. Click on the Prompt when run check box next to the input filename parameter of the Comparative Marker 
Selection analysis. The Web Client removes the parameter value from the pipeline definition. 

2. Click on the Prompt when run check box next to the cls filename parameter of the Comparative Marker 
Selection analysis. The Web Client removes the parameter value from the pipeline definition. 

 
3. Optionally, click set prompt when run display settings to modify the default text of the prompt. 

4. The data (res) files to be analyzed is also named in the dataset  filename parameter of the Extract Comparative 
Marker Results analysis. Modify the pipeline to have it prompt you for this parameter value also: 

1. Click on the Prompt when run check box next to the dataset  filename parameter of the Extract Comparative 
Marker Results analysis: 

 
2. Optionally, click set prompt when run display settings to modify the default text of the prompt. 

5. Scroll to the end of the pipeline definition. 

6. Click Save. The Web Client displays a message confirming that the pipeline has been saved. 

7. Click Return to Modules & Pipelines Start to return to the Web Client start page. 

Running the Edited Pipeline 
To run the edited pipeline: 

1. In the Modules & Pipelines pane, select your pipeline. The Web Client displays the pipeline and its parameters in 
the center pane. 
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2. For the ComparativeMarkerSelection input filename parameter, select all_aml_test.res. 

3. For the ComparativeMarkerSelection cls  filename parameter, select all_aml_test.cls. 

4. For the ExtractComparativeMarkerResults dataset filename parameter, select all_aml_test.res. 

5. Click Run. The Status page appears and GenePattern runs each module. After a few moments, GenePattern 
displays the HeatMapViewer. 

6. Close the HeatMapViewer. 

7. In the Web Client, click Return to Modules & Pipelines Start to return to the Web Client start page. 

Saving and Deleting Result Files 
As described earlier in the tutorial, analyses are run on the GenePattern server and analysis results files are stored 
on the server. Server storage is temporary and analysis results files are deleted after they have been on the server 
for a certain length of time (by default, one week). 

To save your analysis results files, you must copy each file from the server to a more permanent location. If you do 
not need your analysis results, you can delete them from the server at any time (deleted files are not visible from the 
Web Client). 

To save an analysis results file: 

1. In the Recent Jobs pane, click the icon next to a results file. 

2. Click Save. 

To delete an analysis results file: 

1. In the Recent Jobs pane, click the icon next to a results file. 

2. Click Delete. 

To save or delete a job and all of its analysis results files, click the icon next to the job and click Download or Delete. 

Next Steps 
To learn how to use the GenePattern Desktop Client, continue with the next part of the tutorial. 

To exit from GenePattern, go to Part 3: Shutting Down the GenePattern Server. 

Part 2: Using the GenePattern Desktop Client 
This part of the tutorial introduces you to the GenePattern Desktop Client. In this part, you learn how to: 

● Install the Desktop Client. 

● Start the Desktop Client. 

● Run analysis tools. 

● Review analysis results. 

● Save and delete analysis results files. 

● Create a pipeline that runs a sequence of analyses. 
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● Synchronize the GenePattern Desktop Client with the GenePattern server. 

Installing the Desktop Client 
If you have not already installed the Desktop Client, install it now: 

1. Download the installer for the Desktop Client: 

1. Start the Web Client by double-clicking on the GenePattern Web Client icon, shown below. By default, the 
GenePattern installation places this icon on your desktop. 

 
2. Select Downloads>Install Desktop Client. 

 
The Web Client displays the software download page of the GenePattern web site. 

3. Download the client installer for your platform. 

2. Double-click on the downloaded installation file, GenePatternClient.exe, to begin the installation. 

3. Follow the on-screen instructions. 

Starting the Desktop Client 
To start the GenePattern Desktop Client, double-click the GenePattern Desktop Client icon, shown below. By default, 
the GenePattern installation places this icon on your desktop. 

 
A message informs you that the Desktop Client is retrieving modules and jobs from the GenePattern server. After a 
few seconds, the Desktop Client displays its welcome message: 
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Notice the following elements of the Desktop Client window: 

● The title bar shows you the GenePattern server and user name that you are using. The Desktop Client, which 
remains connected to the server throughout the session, runs all of your analyses on this server. Typically, your 
GenePattern user name is your e-mail address. 

● The Projects panel lists your project directories; that is, the directories holding the data files that you are 
analyzing. When you first start the Desktop Client, this panel is empty. 

● The Results panel lists each analysis that you have run and its generated analysis results files. (If you have run 
analyses in the Web Client, the analysis jobs and analysis results files are listed here.) 

● The panel on the right, which displays the welcome message, is the main window. The Desktop Client uses this 
window to display information and to prompt you for input. 

● The menu bar lists the Desktop Client commands. 

For more information: see Menu Bar in the GenePattern Desktop Client Guide. 

Adding a Project Directory 
In the GenePattern Desktop, the directory that holds the files that you want to analyze is called a project directory. 
You do not have to add your project directories to the GenePattern Desktop Client, but doing so makes it easier to 
work with the files in those directories. 

In this tutorial, you are analyzing the files in the gp_tutorial_files/all_aml directory. To add this project 
directory to the GenePattern Desktop Client: 

1. Select File>Open Project Directory. GenePattern displays the Choose a Project Directory window: 
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2. In the Choose a Project Directory window, navigate to the gp_tutorial_files/all_aml directory and 
click Select Directory. GenePattern adds that directory to the Projects pane: 

 
3. In the Projects pane, double-click the directory name to see the files in the directory: 

 
For more information: see Projects Pane in the GenePattern Desktop Client Guide. 
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Running Analyses 
After adding the project directory, you are ready to begin analyzing your data. In this section, you learn how to: 

● Run the ComparativeMarkerSelection analysis to find the genes in the dataset (,res) file that are most closely 
correlated with phenotypes in the class (.cls) file. 

● Run the ComparativeMarkerSelectionViewer to examine the analysis results. 

● Run the ExtractComparativeResults analysis to extract the most promising marker genes from your dataset. 

● Run the HeatMapViewer to display a color-coded map showing the expression levels of the marker genes. 

Running Comparative Marker Selection 
To run the Comparative Marker Selection analysis against the all_aml_train (res and cls) files in your project 
directory: 

1. Select Analysis>Gene List Selection>ComparativeMarkerSelection. The analysis and its parameters appear in 
main window: 

 

2. For the input filename parameter, select the all_aml_train.res file: 

1. Right-click the all_aml_train.res file in the Projects pane. The following context menu appears: 

 
2. Select Send to>input filename. GenePattern sends the file to the input filename parameter. 
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Most commands are available from either the menu bar or a context menu. In this step, you used a context menu 
to set the input filename parameter. In the next step, you use the menu bar to set the cls filename parameter. 

3. For the cls filename parameter, select the all_aml_train.cls file: 

1. Click the all_aml_train.cls file in the Projects pane to select it. 

2. Select Projects>Send to>cls filename. GenePattern sends the file to the cls filename parameter: 

 
Leave the remaining parameters set to their default values. 

4. Optionally, click Help (at the bottom of the main window) to view the documentation for this analysis. Each 
analysis module has its own documentation. 

5. Click Run to start the analysis. The analysis appears in the Results panel with a status of Processing: 
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For more information: see Running Analysis and Visualization Modules in the GenePattern Desktop Client Guide. 

Checking Job Status 
When you click Run to start an analysis, the GenePattern Desktop Client sends your analysis request to the 
GenePattern server. The GenePattern server runs your analysis. When the analysis completes, the GenePattern 
server notifies the GenePattern Desktop Client. The GenePattern Desktop Client then notifies you in two ways: 

● In the Results pane, the Desktop Client updates the Completed column to show the data and time the analysis 
finished: 

 
● By default, the Desktop Client also adds each finished analysis to the Recently Completed Jobs window. If this 

window is not open, the Desktop Client opens it: 

 
You can use File>Alert On Job Completion to control whether or not the Desktop Client uses the Recently 
Completed Jobs window. If the menu item has a check mark, GenePattern updates the window, opening it if 
necessary; otherwise, it does not. To toggle the check mark, select the menu item. 

Click Close to close the Recently Completed Jobs window. 

Reviewing the Results 
When your analysis completes, the analysis results files appear under the analysis name in the Results pane. 
Double-click the analysis name to see the results files: 
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For more information: see Results Pane in the GenePattern Desktop Client Guide. 

An analysis generates multiple analysis results files, including the results of the analysis, an execution log file, and 
sometimes additional message or error logs. You can view analysis results in many ways: 

● Results>Open With>Text Viewer displays the selected file in a text viewer. This is generally the best way to view 
log files. 

● Results>Open With>Default Application displays the selected file in the default application (if any) associated 
with this file type. This can be useful when you have used your operating system to assign default applications to 
particular file types. 

● Results>Modules lists the modules in the Visualization menu that can be used to view the selected file. You 
select the module to use and run it as you did the analysis. This is generally the best way to view analysis results 
since the Visualization modules are designed for this purpose. 

To view the results of the Comparative Marker Selection analysis: 

1. Right-click the execution log file, gp_task_execution_log.txt, and select Open With>Text Viewer.  

GenePattern displays the execution log in a text viewer: 
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2. Close the text viewer by clicking the Close (X) icon in the upper right corner. 

3. Right-click the analysis results file, all_aml_train.comp.marker.odf, and select Open With>Text Viewer. The 
amount of information it contains makes the file difficult to understand. This file, like most analysis results file, is 
not intended to be viewed as a text file, but rather intended to be used as input to subsequent analyses. 

Running the Comparative Marker Selection Viewer 
After running the ComparativeMarkerSelection analysis, run the ComparativeMarkerSelectionViewer to examine the 
analysis results. To run the ComparativeMarkerSelectionViewer: 

1. In the Results pane, right-click the analysis results file, all_aml_train.comp.marker.odf, and select 
Modules>ComparativeMarkerSelectionViewer. The visualization module and its parameters appear in main 
window. Notice that the file you selected has been sent to the input filename parameter. 

2. For the dataset  filename parameter, select the all_aml_train.res file: 
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3. Click Run to run the visualization module. After a few moments, the Comparative Marker Selection Viewer 

window appears: 
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Note: If the top portion of the viewer is blank, click Window>Upregulated Features to refresh the viewer. 

4. In the ComparativeMarkerSelectionViewer: 

▪ The Score column shows the value of the metric used to correlate gene expression and phenotype. A high 
score indicates correlation with the first phenotype (upregulated in ALL) and a low score indicates correlation 
with the second phenotype (upregulated in AML). 

▪ The middle columns, FDR through FWER, provide different ways to measure the significance of the score. 
The lower the value the more significant the result. For example, you might choose to measure significance 
using the false discovery rate (FDR) and set a significance cutoff of FDR < .05. Using this measure, you 
would focus on genes with the lowest and highest scores, where the measure of significance for the score 
was an FDR < .05. 

5. To view the documentation for the Comparative Marker Selection Viewer, return to the Desktop Client window 
and click Help. Like analysis modules, each visualization module has its own documentation. 

6. To close the Viewer window, return to the Viewer window and click the Close (X) icon in the upper right corner. 

In the Desktop Client window, you might notice that the Comparative Marker Selection Viewer module is not listed in 
the Results pane. This is because the viewer runs on the Desktop Client, not the GenePattern server. 
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Running Extract Comparative Results 
Now that you have examined the ComparativeMarkerSelection analysis results, you want to create a new dataset 
that contains only the most promising marker genes from the results file for further analysis. To run the 
ExtractComparativeResults analysis: 

1. Right-click the analysis results file, all_aml_train.comp.marker.odf, and select 
Modules>ExtractComparativeMarkerResults. The analysis and its parameters appear in the main window. Notice 
that the file you selected has been sent to the comparative marker selection filename parameter. 

2. For the dataset filename parameter, select the all_aml_train.res file. 

3. For the field parameter, select Rank. 

4. For the max field, enter 100. 

By entering these values, you are creating a dataset based on the top 100 features (genes) in the analysis 
results file, all_aml_train.comp.marker.odf: 

 
5. Click Run to start the analysis. The analysis appears in the Results panel with a status of Processing. 

When the analysis completes, the Desktop Client updates the Completed column to show the data and time the 
analysis finished and (optionally) adds the finished analysis to the Recently Completed Jobs window. 

6. Click Close to close the Recently Completed Jobs window. 

For more information: see Running Analysis and Visualization Modules in the GenePattern Desktop Client Guide. 

Running the Heat Map Viewer 
The HeatMapViewer displays expression values in a color-coded heat map. The largest expression values are 
displayed in red (hot) and the smallest values are displayed in blue (cool). Intermediate values are displayed in 
different shades of red and blue. The color-coding provides a quick coherent view of gene expression levels. 
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To display your new dataset in the HeatMapViewer: 

1. In the Results pane, double-click ExtractComparativeMarkerResults to see the results files. 

2. Find the analysis results file, all_aml_train.comp.marker.filt.res. (To widen the Name column, 
click-and-drag the line between the Name and Kind column headings.) 

3. Right-click the analysis results file and select Modules>HeatMapViewer. The visualization module and its 
parameters appear in main window. Notice that the selected file has been sent to the input filename parameter: 

 
Click Run to run the visualization module. After a few moments, the Heat Map Viewer window appears. The 
viewer displays dataset expression values in a heat map format: the largest values are displayed as the reddest 
(hot), the smallest values as the bluest (cool), and the intermediate values as shades of blue and red. You can 
see by visual inspection which genes are closely correlated with which phenotype. 
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4. In the Viewer window, adjust the grid size for a clearer view of the sample and feature names: 

3. Click Edit>Display Options. 

4. Click-and-drag the Grid Size  slider 4 or 5 points to the right. The Viewer displays the grid using larger cells.  

5. Optionally, to view the documentation for the Heat Map Viewer, return to the Desktop Client window and click 
. Help

6. To close the Viewer window, return to the Viewer window and click the Close (X) icon in the upper right corner. 

You have successfully run an Extract Comparative Marker Results analysis and reviewed the results using the Heat 
Map Viewer.  
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Using Pipelines 
As you have seen, the GenePattern Desktop Client makes it easy to run individual analyses and to review analysis 
results. GenePattern pipelines take this one step further: they make it easy to run multiple analyses. You can define a 
pipeline to run multiple analyses against a single dataset or to run a sequence of analyses, where the output from 
one analysis becomes the input for a subsequent analysis. 

In this tutorial, you have so far run two analyses: Comparative Marker Selection and Extract Comparative Marker 
Results. The analysis results file from your first analysis became the input file for your second analysis. By running 
these two analyses, you produced a new dataset that contains the 100 genes in your dataset 
(all_aml_train.res) that are most closely correlated with phenotypes in your class file 
(all_aml_train.cls). 

In this section, you will 

● Create a pipeline that duplicates your analysis results. 

● Run the pipeline. 

For more information: see Working with Pipelines in the GenePattern Desktop Client Guide. 

Creating a Pipeline Based on Previous Results 
You can create a pipeline in one of two ways: 

● You can create an empty pipeline and then add to it the analysis modules that you want the pipeline to run.  

● You can create a pipeline based on an analysis results file and have the Desktop Client add to the pipeline the 
analysis modules used to create that results file. After creating the pipeline, the Desktop Client uses the following 
steps to determine which modules to add to the pipeline: 

1. It adds the module that created the results file. 

2. It checks the module’s input file parameter. 

3. If the input file for the module was the output file of a previous module, the Desktop Client adds the previous 
module and returns to step 2; otherwise, there are no more modules to be added to the pipeline. 

To create a pipeline based on the analysis results file from the Extract Comparative Marker Results analysis: 

all_aml_train.comp.marker.filt.res1. Right-click the analysis results file, , and select Create 
Pipeline. The Desktop Client prompts you for a pipeline name: 

 
2. Enter a name for the pipeline, my.comparative.marker, and click OK. The Desktop Client displays the new 

pipeline and its definition: 
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The Desktop Client created the pipeline and then added to it the module that created the results file, Extract 
Comparative Marker Results. The input file for the Extract Comparative Marker Results module was the output 
file from Comparative Marker Selection, so the Desktop Client added the Comparative Marker Selection module 
to the pipeline.  

Adding Modules to a Pipeline 
The pipeline contains the two analysis modules used to create the analysis results file: Comparative Marker Selection 
and Extract Comparative Marker Results. In your original analysis, after creating the analysis results file, you used 
the Heat Map Viewer to review the results. 

To add the Heat Map Viewer module to your pipeline: 

1. Click  (at the bottom of the window). The Desktop Client opens the pipeline definition for editing: Edit
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2. Click on the second module in the pipeline, ExtractComparativeMarkerResults, to select it. 

3. Click  (near the top of the window). The Desktop Client displays the Add Module window. Add Module After

4. Select Visualizer from the Category list. (You may need to scroll the list.) The Desktop Client populates the 
Module list with all of the modules in the Visualization menu. 

5. Select HeatMapViewer from the Module list: 

 
6. Click OK. The Desktop Client adds the HeatMapViewer module after the ExtractComparativeMarkerResults 

module in the pipeline definition window. 

7. Make the value of the filename parameter for the HeatMapViewer the analysis results file from the 
ExtractComparativeMarkerResults module: 
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1. Select the Use output from previous task check box. The Desktop Client adds the Choose Task drop-down 

list to the filename parameter field.  

2. Select ExtractComparativeMarkerResults from the Choose Task drop-down list. The 
ExtractComparativeMarkerResults module generates multiple analysis results files; therefore, the Desktop 
Client adds the Dataset drop-down list to the filename parameter field. 

3. Select res from the Dataset drop-down list. 

8. Click Save (at the bottom of the window) to save your changes. The Desktop Client saves the pipeline and 
displays the following confirmation message: 

 
9. Click OK to close the confirmation message window. 

Editing a pipeline always creates a new version of this pipeline. This ensures that you can always reproduce any 
analysis that you have run, even if you subsequently change the pipeline that you originally used to run the analysis. 

For more information: see Understanding Version Numbers in the GenePattern Concepts Guide. 

Running the Pipeline 
To run the pipeline: 

1. Select Pipelines>my.comparative.marker. (Notice that the pipeline names are color-coded; the pipelines you 
create are displayed in pink.) The Desktop Client displays your pipeline in the main window: 
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2. Click Run to run the pipeline. The pipeline name appears in the Results window with a status of processing. After 

a short time, the Heat Map Viewer appears and the pipeline completes.  

When the pipeline completes, the Desktop Client updates the Completed column to show the data and time the 
analysis finished and (optionally) adds the finished pipeline to the Recently Completed Jobs window. 

3. Close the Heat Map Viewer and the Recently Completed Jobs window. 

4. Double-click the pipeline name in the Results pane to see the analysis results files. Notice that all of the results 
files for all of the analyses appear under the pipeline name. 

Analysis and visualization modules run from a pipeline work exactly the same as those run directly from the 
Desktop Client. If you run a Viewer from a pipeline, it gets displayed just as if you ran it directly from the Desktop 
Client. Analysis results files generated by a pipeline are exactly the same as those generated by modules run 
directly from the Desktop Client. 

Saving and Deleting Analysis Results 
As described earlier in the tutorial, when you run an analysis or a pipeline, the Desktop Client sends your request to 
the GenePattern server. The GenePattern server runs the analysis and notifies the Desktop Client when the analysis 
or pipeline completes. The analysis results files that appear in the Results pane of the Desktop Client window are 
actually stored on the GenePattern server. Server storage is temporary and analysis results files are deleted after 
they have been on the server for a certain length of time (by default, one week). 

To save your analysis results files, you must copy each file from the server to a more permanent location. If you do 
not need your analysis results, you can delete them from the server at any time, which also removes them from the 
Results pane. 

To save an analysis results file: 
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1. In the Results pane, click the file that you want to save. For example, click the analysis results of the 
ExtractComparativeMarkerResults analysis, all_aml_train.comp.marker.filt.res. 
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2. Select Results>Save To. GenePattern displays the Save To submenu, which lists your project directories and an 
 item. Other

3. Select your project directory. GenePattern copies the file to the selected directory and then refreshes the 
Projects pane to include the new file: 

 
You can delete an analysis results file in much the same way that you save one: click the file that you want to delete 
and select Results>Delete File. Or, you can delete an analysis and all of its results files. To delete an analysis and its 
results files: 

1. In the Results pane, click the analysis that you want to delete. For example, click the 
ExtractComparativeMarkerResults analysis. 

2. Select Results>Delete Job. A confirmation window appears: 

 
3. Select Yes to delete the job and its analysis results files. The GenePattern Client deletes the analysis and all its 

results files from the GenePattern server and the Results pane. Notice that the file you saved is not affected; it 
remains in your project directory.  

For more information: see Working with Analysis Results in the GenePattern Desktop Client Guide. 

Synchronizing the Desktop Client and Server 
The GenePattern Desktop Client is a software application. When you start the Desktop Client, it connects to the 
GenePattern server, reads information from the server, and builds the application interface. The Analysis, 
Visualization, Pipelines, and Suites menus and the contents of the Results pane all reflect information read from the 
GenePattern server at a particular point in time. Periodically, the Desktop Client retrieves updated information from 
the GenePattern server; for example, when you run an analysis, the Desktop Client updates the Results pane to 
include the new analysis results files. However, you may need to refresh the Desktop Client to ensure that the 
information it displays reflects the current content of the GenePattern server. 

To see how this works, you will use the Web Client to make a few changes to the GenePattern server. Then, you will 
return to the Desktop Client, notice that it does not reflect the changes that you made, and refresh the display. 

To make a few changes in the Web Client: 

1. Start the GenePattern Web Client: 

1. Double-click the GenePattern Web Client icon: 



 
2. When the Web Client displays the login page, enter your username (or username and password). 

3. Click Sign In. The Web Client displays the start page. 

2. Notice that the Recent Jobs pane lists the jobs that you have run in Desktop Client: 

3. Delete by most recent job: 

1. Note the job number. Later, you will look for this job in the Desktop Client. 

2. Click on the icon next to the job name to display the job menu. 

3. Click Delete. 

4. Notice that Modules & Pipelines pane lists the pipeline that you created in the Desktop Client: 

5. Delete the pipeline: 

1. Click Modules & Pipelines>Manage. 

2. Click the check box next to the name of your pipeline. The Web Client selects all versions of your pipeline. 

3. Scroll to the bottom of the page and click delete (at the bottom of the column of check boxes). The Web 
Client deletes all versions of your pipeline. 

Now, examine your changes in the Desktop Client: 

1. Return to the Desktop Client. 

2. Examine the Results pane. Notice that it lists the job that you deleted using the Web Client: 

3. Click File>Refresh>Jobs. The Desktop Client connects to the GenePattern server, retrieves information about all 
analyses that you have run, and updates the Results pane. The deleted job disappears. 

4. Examine the Pipelines menu. Notice that it includes the my.comparative.marker pipeline, which you deleted 
using the Web Client. 

5. Click File>Refresh>Modules. The Desktop Client connects to the GenePattern server, retrieves the list of 
modules (analysis modules, visualization modules, pipelines, and suites) from the server, and updates the 
Analysis, Visualization, Pipelines, and Suites menus. 

6. Examine the Pipelines menu. Notice that it no longer includes the my.comparative.marker pipeline. 

Part 3: Shutting Down the GenePattern Server 
Shutting Down GenePattern 
When you are finished working with GenePattern, you can shutdown both the clients and the server. Remember that 
the clients are connected to the server; therefore, you want to exit from the clients before you shutdown the server. If 
you shutdown the server first, the clients will display error messages as they attempt to contact the server. 

To exit from GenePattern: 

1. Exit from the Desktop and Web clients. 

▪ To exit from the GenePattern Desktop Client, select .  File>Quit

▪ To exit from the GenePattern Web Client, click the sign out link in the top right corner of the title bar and 
then close the web browser window. 

2.  Shutdown the server by double-clicking the Stop GenePattern Server icon, shown below. Alternative: if you are 
using Windows, you can close the console window. 
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On Windows, when you shutdown GenePattern, the GenePattern console window closes. On Mac OS X, the 
GenePattern server icon disappears from the Dock. On Linux machines, the GenePattern server exits silently. 

Learning More About GenePattern 
Thank you for taking this time to learn about GenePattern! 

As you continue to work with GenePattern, please visit the GenePattern web site, which provides an overview of the 
GenePattern analysis modules, as well as links to the GenePattern software and documentation. 

We welcome your feedback. If you have suggestions, comments, or questions that are not answered by the 
documentation, contact the GenePattern help desk (gp-help@broad.mit.edu). 
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